The end of life (EOL) date for this module was 30 September, 2018.

Active Console Lite

User Interface

Components of AC Lite

The following figure describes the main components of AC Lite:

The title bar of the application displays the current workspace and its location while the status bar of AC Lite displays the Open Access host and the build version of the application.

AC Lite has a menu bar with options to manage the opening and saving of workspaces as well as the access to the connection dialog to Open Access.

The menu bar also has access to the components which are used to view the data fed by Open Access. These components reside in dockable frames which can be dragged around the AC Lite application or be floated. At any given time, only a single dockable component is selected. This is indicated by the blue title bar of the dockable.

Visual Indicators

AC Lite uses icons and colour to convey information about the state of the system in a simple and effective manner.

Icons

There are 3 types of icons being used in AC Lite

  • Icons which are related to data items, group folders, dockables, and AC Lite application. These icons reflect the severity property.
  • Icons used as overlays in data item icons in order to reflect additional information as to the state of the data item excluding headlines and cells.
  • Icons which are relevant to headlines and cells.
Severity Colour

The colour of data item icons is provided by severity rules defined in gateways and enforced in the data collected from netprobes and gateway plugins. Open Access transmits the data with their severity property to AC Lite which then uses this information to prepare the display and convey the state of the system.

Parent items acquire the worst severity from their child items. This approach permits the State Tree icon to reflect the overall severity of the system and change the severity of the AC Lite icon in the title bar of the application accordingly.

Similarly, metrics and list view icons reflect the worst severity of the items they contain.

The colour code is the following:

  • Grey: no severity rule has been triggered on the data item or its children so its severity is UNDEFINED.
  • Green: a severity rule has been triggered that tells the system that the data item or its children are OK.
  • Amber: a severity rule has been triggered that tells the system that the data item or one of its children is in a WARNING state. This colour will override Green.
  • Red: a severity rule has been triggered that tells the system that the data item or one of its children is in a CRITICAL state. This colour will override Amber.
Other Visual Indicators

Data views indicate Snoozed headlines and table cells by adding a blue border while Inactive cells are noted by their blue background.

List views indicate Severity, Snoozed and Inactive properties of data items in the Severity column. Snoozed items have a blue border and Inactive items have a blue background.

Access to functionality through context sensitive menus

Right-click menu options provide access to functionalities relevant to the component or data items from which the menu was invoked.

Right-click menu options for AC Lite components

AC Lite component Functionality Right-click menu option

State Tree

Switching between Logical and Physical modes

Defining the view path. It uses the managed entity attributes to sort the tree into logical groups.

Enable/Disable Logical Mode

Set Viewpath (Available for Logical Mode only)

Status Overview

Grouping or ungrouping of data items

Group By

Ungroup

Multiple Grouping

List View (custom list)

Grouping or ungrouping of data items

Changing the list view name

Entering xpaths for data items to display

Group By

Ungroup

Multiple Grouping

Configure

Metrics view (view selector)

Grouping or ungrouping of dataviews in view selector

Changing the metrics view name

Entering xpaths for dataviews


Group By

Ungroup

Multiple Grouping

Configure (Available for custom metrics only)

Options related to data items are added to the right-click menu of the component.

Right-click menu options for data items

AC Lite data item Functionality Right-click menu option

All data items

Access to Commands relative to the data item.
Copying data item path to clipboard.
Commands...->
Copy Path

Managed Entity

Creating custom views based on the child items of the selected Managed Entity. Create Metrics View Tab Create Listview Tab (Available in State Tree only)

A special case is represented by components that need to be populated with live data in order to present a right-click menu.

Right-click menu for components that need to be populated

AC Lite data item Functionality Right-click menu option
Metrics view (dataview)

Functionality for column headings

  • Auto-resizing columns
  • Hiding columns
  • Selecting columns for display
  • Restoring hidden columns





Functionality for headlines and table cells

  • Access to Commands
  • Copying cell path to clipboard
  • Copying cell value to clipboard
Auto Resize This Column
Auto Resize All Columns
Hide This Column
<list of column headings to check/uncheck>
More… (leads to ‘Choose Columns to Display’ dialog)
Reset to Default

(Available if right-clicking on a column heading)


Commands… ->
Copy Path
Copy Value

(Available if right-clicking on a headline or table cell)

Command viewer Removing individual or all commands
Remove command
Remove All Commands

Installing AC Lite

  1. Retrieve the binary from the customer area on the Geneos website.
  2. Extract/Unzip the binary to a writable location. This will become the installation directory
  3. The installation directory will have the following folders and files:

    • conf
    • jre
    • lib
    • ac-app-1.0.jar
    • aclite.exe
    • aclite.l4j.ini
    • aclite-cmd.exe
    • aclite-cmd.l4j.ini
  4. Check the connection protocol used by Open Accesss for AC Lite.
  5. If Open Access is using a tcp connection, then there are no configuration changes to be implemented in AC Lite and the application is ready to get started.
  6. If Open Access is using SSL connection, then AC Lite needs to be prepared to act as SSL client. Please consult with your Open Access administrator how to get the public/private keys defined.

Enabling SSL connection in AC Lite

If Open Access requires an SSL connection, then AC Lite needs to be prepared as an SSL client, do the following:

  1. Consult with your Open Access administrator how to get the SSL public/private keys defined and establish the keystore and truststore files for AC Lite.
  2. Find the openaccess.conf.template in the installation directory under the conf folder and rename it as openaccess.conf.
  3. Edit the SSL fields in openaccess.conf.
  4. Leave the Port field as 0 (this field refers to AC Lite port as an SSL client).
  5. Input the required Open Access cluster and nodes in the Connection dialog. At start-up, AC Lite will note the presence of the openaccess.conf file and will automatically add an “SSL Enabled” label in the Connection dialog.

Getting Started with AC Lite

Launching AC Lite

  1. Double-click on aclite.exe in the installation directory. AC Lite displays the default workspace with a dialog to set the connection to Open Access.

Note: Double-clicking on aclite-cmd.exe will start AC Lite and a cmd window to display the log dynamically.

  1. Set the Open Access connections in the ‘Connection Details’ dialog. By clicking on the ‘+’ sign a new dialog appears, ‘Cluster Configuration’. You should know the connection details to Open Access as they are related to its configuration. Press the Ok button to save the cluster configuration and close the dialog.

Note: If the connection to Open Access is SSL and there is an openaccess.conf with the SSL details of AC Lite, then the dialog will display an “SSL Enabled” label.

AC Lite can connect to multiple Open Access clusters, where each cluster may include many nodes.

By pressing the Connect button, the status of the connection will change from ‘Idle’ to ‘Connecting…’ and finally ‘Connected’. At this point, the State Tree will be populated with the contents of the gateways feeding into Open Access. Close the ‘Connection Details’ dialog.

Displaying Gateways and NetProbes in the State Tree

By default, the State Tree displays in Logical mode, this implies a hierarchy of data items ordered by managed entity metadata. Disabling Logical mode through the right-click menu will change the State Tree mode to Physical, which will reorder the hierarchy of data items starting with Gateways and their NetProbe child items.

Rearranging the State Tree on the basis of Managed Entity attributes

  1. Right-click on the State Tree and select ‘Set Viewpath’ from the menu. This option is only available if the State Tree is in Logical mode.
  2. In the ‘Viewpath Configuration’ window, move the required attributes to the right panel.
  3. Order the attributes in the right panel in the desired sequence.
  4. Press OK button to close the ‘Viewpath Configuration’ window. The State Tree display will be updated according to the configured viewpath.

Configuring AC Lite

Creating a Custom Metric

There are two ways to create a custom metric, either via the State Tree or through the View menu:

Creating a custom metric for a selected Managed Entity in the State Tree

  1. Right-click on a Managed Entity in the State Tree.
  2. Select ‘Create Metrics View Tab’ from the menu. A new metrics appears with the name ‘Metrics View x’ where x is a consecutive number starting with 0. The new metrics lists the dataviews under the selected Managed Entity and displays the first dataview in the list.

Creating a custom metric from View menu

  1. Select ‘Metrics’ from View/New menu.
  2. A new metrics appears with the name ‘Metrics View x’ where x is a consecutive number starting with 0. The new metrics is blank and is ready to be configured with a user-defined path.

Configuring a Path for a Custom Metric

  1. Select the ‘Configure’ option from the right-click menu of the custom metric to retrieve the Configuration dialog.
  2. Press ‘+’ to add a path.
  3. Replace //dataview[0] with your path leading to dataview.
  4. Press ‘Apply’ button and close the window.
Path Result in view selector of Metrics
//dataview
Or
/geneos/gateway/directory/probe/managedEntity/sampler/dataview
All dataviews (Not recommended as it may impair performance)
//dataview[(@name=“CPU”)]
Or
/geneos/gateway/directory/probe/managedEntity/sampler/dataview[(@name=“CPU”)]
All CPU dataviews are listed
// dataview[(state(“severity”)=“3”)]
Or
/geneos/gateway/directory/probe/managedEntity/sampler/dataview[(state(“severity”)=“3”)]
All dataviews with severity Critical
// dataview[(state(“snoozed”)=“1”)]
Or
/geneos/gateway/directory/probe/managedEntity/sampler/dataview[(state(“snoozed”)=“1”)]
All snoozed dataviews
//gateway[(@name=“GW_304”)]//dataview
Or
/geneos/gateway[(@name=“GW_304”)]/directory/probe/managedEntity/sampler/dataview
All dataviews under gateway GW_304
//gateway[(@name=“GW_304”)]//managedEntity[(@name=“ME_304B1”)]//dataview
Or
/geneos/gateway[(@name=“GW_304”)]/directory/probe/managedEntity[(@name=“ME_304B1”)]/sampler/dataview
All dataviews for managed Entity ME_303B1 in gateway GW_304
//gateway[(@name=“GW_304”)]//managedEntity[(state(“snoozed”)=“1”)]//dataview
Or
/geneos/gateway[(@name=“GW_304”)]/directory/probe/managedEntity[(state(“snoozed”)=“1”)]/sampler/dataview
All dataviews under snoozed managed Entities in gateway GW_304
//managedEntity[(state(“severity”)=“3”)][(state(“userAssigned”)=“1”)]//dataview
Or
/geneos/gateway/directory/probe/managedEntity[(state(“severity”)=“3”)][(state(“userAssigned”)=“1”)]/sampler/dataview
All dataviews under critical managed Entities which have been assigned to a user

Creating a Custom List

There are two ways to create a custom list, either via the State Tree or through the View menu:

Creating a custom list for a selected Managed Entity in the State Tree

  1. Right-click on a Managed Entity in the State Tree.
  2. Select ‘Create List View Tab’ from the menu. A new custom list appears with the name ‘List View x’ where x is a consecutive number starting with 0. The new custom list displays the Samplers under the selected Managed Entity.

Creating a custom metric from View menu

Select ‘List View’ from View/New menu. A new custom list appears with the name ‘List View x’ where x is a consecutive number starting with 0. The new custom list is blank and is ready to be configured with a user-defined path.

Configuring a Path for a Custom List

  1. Select the ‘Configure’ option from the right-click menu to retrieve the Configuration dialog.
  2. Press ‘+’ to add a path.
  3. Replace //dataview[0] with your path.
  4. Press ‘Apply’ button and close the window.

Path examples to populate a custom list

Path Result in view selector of Metrics
//gateway
Or
/geneos/gateway/directory
All gateways in the system
//probe
Or
/geneos/gateway/directory/probe
All netprobes
//managedEntity
Or
/geneos/gateway/directory/probe/managedEntity
All managed entities
//sampler
Or
/geneos/gateway/directory/probe/managedEntity/sampler
All samplers
//dataview
Or
/geneos/gateway/directory/probe/managedEntity/sampler/dataview
All dataviews
/geneos/gateway/directory[(state(“severity”)=“3”)]
Only gateways with severity critical
//probe[(rparam(“Version”)=“GA3.0.17-140205”)]
Or
/geneos/gateway/directory/probe[(rparam(“Version”)=“GA3.0.17-140205”)]
Only netprobes version GA3.0.17-140205
//managedEntity[(attr(“Country”)=“UK”)]
Or
/geneos/gateway/directory/probe/managedEntity[(attr(“Country”)=“UK”)]
Only managed entities with attribute Country = UK
//sampler[(param(“Group”)=“IT_utilisation_group”)]
Or
/geneos/gateway/directory/probe/managedEntity/sampler[(param(“Group”)=“IT_utilisation_group”)]
Only samplers from the sampler group IT_utilisation_group
//dataview[(@name=“CPU”)]
Or
/geneos/gateway/directory/probe/managedEntity/sampler/dataview[(@name=“CPU”)]
Only dataviews named CPU
//managedEntity[(@name=“ME_toolkitA”)]//dataview[(@name=“toolkitA”)]/rows/row/cell
Or
/geneos/gateway[(@name=“GW_304”)]/directory/probe[(@name=“probe_304A”)]/managedEntity[(@name=“ME_toolkitA”)]/sampler[(@name=“toolkitA”)][(@type=“”)]/dataview[(@name=“toolkitA”)]/rows/row/cell
All the cells of a specific dataview. The example is dataview toolkitA under managed Entity ME_304A.
//managedEntity[(@name=“ME_toolkitA”)]//dataview[(@name=“toolkitA”)]/headlines/cell
or
/geneos/gateway[(@name=“GW_304”)]/directory/probe[(@name=“probe_304A”)]/managedEntity[(@name=“ME_toolkitA”)]
/sampler[(@name=“toolkitA”)][(@type=“”)]/dataview[(@name=“toolkitA”)]/headlines/cell
All the headlines for a specific dataview. The example is for dataview toolkitA under managed entity ME_304A.
//managedEntity[(attr(“Continent”)=“America”)]/ancestor::gateway/directory The parent gateway of a managed entity with specific attribute
//managedEntity[(attr(“Continent”)=“America”)]/ancestor::probe The parent netprobe of a managed entity with specific attribute

Working with AC Lite

Displaying Selected Rows in a Dataview

The dataview presents a quick filter search box at the top right corner which can be used to display selected rows only. Notice that the rows in the dataview are immediately being filtered as you type any character in the search field.

Example showing how filtering by ‘ba’ causes the dataview to show just the bash processes

Changing the Grouping of Dataviews in the Metrics View

By default, dataviews in the metrics view are grouped by Sampler Group. To change the grouping, right-click in the View selector and then select either Group by, or Multiple Grouping.

  • Group By - opens a submenu to select a single property or Managed Entity attribute.
  • Multiple Grouping - retrieves the ‘Group Definition’ dialog where multiple properties or Managed Entity attributes can be selected and arranged in the desired grouping sequence.

To undo any previous grouping, click ‘Ungroup’.

Changing the Grouping in the List View

By default, data items in the list are not grouped. To apply grouping to the list, right-click and then select either Group by, or Multiple Grouping.

Resizing the Columns in a Dataview or a List View

Manual resizing of columns can be executed by positioning the cursor on the right-hand side of the column heading until ↔ appears. Left-click and extend the width of the column.

Alternatively, the right-click menu of column headings offers two ‘Auto Resize…’ options: ‘Auto Resize This Column’ and ‘Auto Resize All Columns’.

To save the column settings in a dataview, press the “Save Table Settings” icon. List view settings will be saved when the workspace is saved.

Selecting the Columns to Display in a Dataview or a List View

By default, all relevant columns are displayed.

To hide some of the columns, right-click on a column heading and then do the following:

  1. Select ‘Hide This Column’ from the menu, or
  2. Uncheck any other column listed in the right-click menu, or
  3. Select ‘More…’ from the menu which retrieves the ‘Choose Columns to Display’ dialog where more than column can be unchecked.

To restore all hidden columns, right-click and then choose, ‘Reset to Default’.

To save the column settings in a dataview, press the “Save Table Settings” icon. List view settings will be saved when the workspace is saved.

Identifying Snoozed Items in the System

The simplest way to identify snoozed items is to create a custom list and configure it.

Note: Do not use ‘*’ wildcard.

To identify snoozed items in the system, do the following:

  1. Open a custom list and then select ‘Configure’ from the right-click menu to retrieve the Configuration dialog.
  2. Input any or all of the following paths by clicking the ‘+’ for every path.
//gateway/directory[(state("snoozed")="1")]
//probe[(state("snoozed")="1")]
//managedEntity[(state("snoozed")="1")]
//sampler[(state("snoozed")="1")]
//dataview[(state("snoozed")="1")]
//headlines/cell[(state("snoozed")="1")]
//rows/row/cell[(state("snoozed")="1")]
  1. Optionally, change the title of the list.
  2. Press the Apply button and then close the Configuration dialog.

The custom list displays all the data items that have been snoozed.

Identifying User Assigned Items in the System

The simplest way to identify all User Assigned items is to create a custom list and configure it.

Note: Do not use ‘*’ wildcard.

To identify user assigned items in the system, do the following:

  1. Open a custom list and then select ‘Configure’ from the right-click menu to retrieve the Configuration dialog.
  2. Input the following paths by clicking the ‘+’ for every path.
//gateway/directory[(state("userAssigned")="1")]
//probe[(state("userAssigned")="1")]
//managedEntity[(state("userAssigned")="1")]
//sampler[(state("userAssigned")="1")]
//dataview[(state("userAssigned")="1")]
//headlines/cell[(state("userAssigned")="1")]
//rows/row/cell[(state("userAssigned")="1")]
  1. Optionally, change the title of the list.
  2. Press the Apply button and then close the Configuration dialog.

The custom list displays all the data items that have been user assigned.

Finding the Gateway or any other parent item for a selected data item

To identify the parent items of a data item including the gateway, you are required to access the path of that data item. Do one of the following:

  1. Right-click on the data item and select ‘Copy Path’ which can then be pasted on a text file.
  2. If the selected data item is in the State Tree, then open the Properties View and look at the path property.
  3. The data item can be dragged and dropped into a custom list and the gateway name will be found under the Gateway column.

Also, grouping by Gateway in metrics and list views allows the gateway identification for items of different sources.

Accessing commands in selected data items for execution

To open a submenu with the commands available to the selected data item, right-click on a data item, and then choose ‘Commands…’

E.g. Commands>Snooze>Manual

Showing Snooze command

Executing commands that require an output

If the required command requires an output, then AC Lite will call the Command Viewer in order to display that output.

To illustrate, when you right-click on a CPU table cell and then select the command ‘Top 20 Processes’, the Command Viewer appears displaying the top 20 processes.

Execution of ‘Top 20 Processes’ command from a CPU table cell retrieves the Command Viewer

Checking commands that have been executed in this session

The Command Viewer lists the commands executed in AC Lite and includes an output area. If the Command Viewer is not on display, it can be retrieved from View menu.

Example showing executed commands

Checking the properties of data items

You can display the properties of any data item in the State Tree through View menu> Properties.

Retrieval of Properties View and display of a managed entity’s properties

Undocking views to have a better view of the data in the system

While creating custom views, AC Lite tends to place them as tabbed components. In order to separate them and be able to distribute them over the screen, the views need to be floated.

To float windows, do either of the following:

  1. Click on the Floating icon of the title bar of the dockable, this becomes a floating window and retains its tabs.
  2. Right-click on the tab and then select ‘Floating’, the individual view becomes a floating window.

The floating windows can then be moved to suitable positions across the screen.

Undocking individual view and a dockable

Docking floating views to mainframe

You can dock individual windows to mainframe by clicking on the Floating icon in the title bar.

However, if there are too many floating windows, you can select ‘Reset Layout’ from the Windows menu to dock them all in one go.

Saving a workspace

You can save a workspace through the File menu; Either choose Save or Save As.

  • Save: it will save the workspace indicated in the AC Lite title bar.
  • Save As…: it opens a dialog that allows the user to provide a different name for the workspace and a different location.

You can also save workspaces as you close AC Lite or when moving to another workspace. In this case, a ‘Save…’ dialog will ask whether to save the workspace that is being closed. This saving action will be applied to the workspace indicated in the AC Lite title bar.

AC Lite workspaces are saved as *.workspace.

Loading a workspace

Loading of a workspace occurs in 2 instances: when starting AC Lite and when calling the File/Open option.

Starting AC Lite

On start-up, AC Lite will automatically try to retrieve the default.workspace file from the location C:\Users\{YourUserName}\.aclite.

If the default workspace is found, then it will be loaded with the connection to Open Access automatically established.

If this file is not found, then AC Lite will provide a new layout and will ask for the connection details to Open Access.

Selecting File/Open menu option

This menu option calls the ‘Open’ window which allows the navigation to the required workspace file and its retrieval.

The selected workspace will load and automatically connect to Open Access.

AC Lite workspaces are identified by the root ‘workspace’.

Creating a new workspace

  1. You can create a new workspace through File/New menu option.
  2. This menu option will provide a new layout and the Connection dialog will appear to input the details of the connection to Open Access.

Note: The AC Lite title bar indicates the default workspace in the user directory. If the Save function is used, then the new workspace will overwrite any previous default workspace file that may have been saved.

We recommend that you use ‘Save As…’ to save a new workspace.

Troubleshooting

Connection to Open Access issues

The state of every connection to Open Access clusters is displayed in the ‘Connection Details” dialog. This dialog can be retrieved from the File menu. The following picture shows one successful connection and two connection issues.

image27

When connecting to multiple clusters, ensure the Gateways are unique. If the same Gateway is used to connect the clusters to the client, the results will be undefined.

Status: Invalid username/password

This error message indicates that Open Access has user authentication enabled and the user information entered in the configuration details of the cluster in AC Lite does not correspond to the user information in Open Access.

Check the accuracy of the ‘Username’ and ‘Password’ fields in the cluster configuration:

  1. Press the Disconnect button in the ‘Connection Details’ dialog
  2. Double-click on the cluster to bring the ‘Cluster Configuration’ dialog

If an error is detected in the Authentication fields then edit the field with the error.

  1. Press OK button to close the Cluster Configuration dialog
  2. Press Connect button in the Connection Details dialog and check that the status of the cluster connection changes to Connected.
  3. Close the Connection Details dialog

If no errors are detected in the Authentication fields, then contact your Open Access administrator to get the details of a working Username and password for the cluster.

Status: Timeout occurred while trying to connect – retrying…

This error message indicates that AC Lite cannot connect to the Open Access cluster. This could be due to:

  1. Seed-node details in the cluster configuration are incorrect
  2. Open Access only accepts SSL connections and AC Lite has not been SSL-enabled
  3. Open Access cluster has gone down and disconnected from AC Lite

Check the accuracy of the cluster configuration:

  1. Press the Disconnect button in the ‘Connection Details’ dialog.
  2. Double- click on the cluster to bring the ‘Cluster Configuration’ dialog.

    If an error is detected in the Seed Nodes configuration then :

    1. Edit the node with the error.
    2. Press OK button to close the ‘Cluster Configuration’ dialog
    3. Press Connect button in the ‘Connection Details’ dialog and check that the status of the cluster connection changes to Connected.
    4. Close the Connection Details’ dialog.

  1. If no errors are detected in the Seed Nodes configuration, then contact your Open Access administrator to query the status of the Open Access cluster and whether it requires AC Lite to be SSL-enabled (see Enabling SSL connection in AC Lite).

Disconnection issues (loss of data in AC Lite)

Open Access disconnection

If gateways and all their contents disappear from the State Tree in AC Lite, then it is likely that a disconnection to a node in an Open Access cluster has occurred.

Select Connection from the File menu to display the ‘Connection Details’ dialog and check the status of the cluster connection.

If the status of the cluster connection is ‘Connected’ then it is likely that the Open Access cluster has been set for failover. In this case the connection will be re-established as another node in the cluster will take over the gateways connections.

If despite the status being ‘Connected’ the gateways do not reappear in the State Tree, then press Disconnect followed by Connect in the ‘Connection Details’ dialog. This action reactivates the connection to Open Access.

If the status of the cluster connection is ‘Timeout occurred while trying to connect – retrying…’, this indicates that the whole cluster has gone down. Contact your Open Access administrator to query the status of the Open Access cluster.

Gateway or Netprobe disconnection

AC Lite displays the Disconnection icon over the gateway or netprobe that has gone down and retains the tree in the State Tree.

Once the gateways or netprobes recover and restart sending data to Open Access, AC Lite removes the Disconnection icons and the data items in the State Tree display as before.

Application error

AC Lite may encounter errors during its operations which will ensue a warning like this:

It is recommended to restart AC Lite if this warning appears and try to reproduce the actions carried out before the error. If the issue persists then contact Geneos Support with a description of the procedure carried out and the log file.

Note: Manual modifications to the workspace file may cause unforeseen errors leading to the display of this warning. It is recommended not to unzip the workspace file and manually edit its configuration file.

Command options not available

AC Lite users can only access the commands that are allowed in the connection between Open Access and the underlying Gateways. If there are missing commands, contact your Open Access administrator in order to modify the restrictions.

Invalid Path

AC Lite displays the following error message if the path applied to a custom metrics does not include a dataview as the last step.

The solution depends on the type of path being applied to the custom metric:

  • Add //dataview if the path was copied from a gateway, netprobe, managed entity or sampler
  • Remove steps in the path up to the dataview, if the path was copied from a headline or table cell