Gateway Setup Editor

Introduction

Gateway Setup Editor (GSE) is a standalone Java and C++ application which allows you to edit the setup of the Gateway. This document is a reference guide which will step you through the major components.

This document assumes the user has a basic understanding of the Geneos framework.

It guides you through the fundamental principles behind the GSE interface and its main components.

Licensing

The GSE is part of the Geneos Framework; therefore if you have a license for the framework you can deploy as many GSE's as you like within the group or organisation that has the license.

Glossary of terms

Term Description
GSE Gateway Setup Editor.
Named item Refers to any item in the setup that can be named, and referred to. Examples include Probes, Samplers and variables.
GA Version General Availability. Geneos products that are in Beta or production are said to be GA's. They have been tested internally by ITRS.
RA Version Restricted Availability. Geneos products that have not been tested, and are considered pre Alpha

General Overview

Starting Gateway Setup Editor

There are two ways to start the Gateway Setup Editor (GSE):

Standalone

Run the GatewaySetupEditor.exe executable located in the directory you installed or unzipped the files in.

There are a number of start-up flags and settings you can define which modify the behaviour and configuration of the GSE while it is running. These settings are configured by modifying the GatewaySetupEditor.gci file that resides in the same directory as the GatewaySetupEditor.exe. For a complete list of these flags, and details of how to change this file, see Start up settings.

From the Active Console 2

The GSE can run from within the Active Console 2.

To launch the GSE without opening a setup, go to Tools > Gateway Setup Editor.

To open an existing Gateway 2 configuration, use one of the following methods:

  • Select Configure gateway from the toolbar, then select a Gateway 2 and press OK.
  • Right-click a Gateway 2 and select Configure gateway.
  • Double-click a Gateway 2 in the Gateways view.

When you run the GSE from the Active Console 2, it adopts all the arguments passed to the Active Console from the ActiveConsole.gci file.

The GSE can be configured to launch as a separate process from the Active Console 2 using the Gateway setup editor as a separate process advanced setting. See Advanced settings.

Opening, saving and closing Gateway setups

Gateway setups can be edited in 2 'modes': From disk or via a Gateway

Opening Gateway setup files from disk

Gateway setup files are XML files, and can be opened from any accessible file location. To do this simply go to File->Open or Use the 'Open Document' button on the toolbar, and select a path using the file open dialog.

Alternatively, you can Drag and Drop a file from external programs, such as Windows Explorer.

Note: Files edited from disk do not benefit from gateway related features, such as gateway validation and file locking. Also, the setup will not get applied to the gateway automatically.

Opening Gateway setups via a Gateway

You can open a setup directly via a gateway connection, when running the GSE standalone. The setup editor can request the setup from a gateway for editing, and then send the setup back to the gateway to be applied.

To open a Gateway setup, you must connect to the Gateway: Go to File->Connect, or select 'Connect to Gateway' from the toolbar. This will open the connection dialog:

gse0

Select the Logon type, host/IP, and the port of a Gateway 2. Press OK and the editor will attempt to connect to the Gateway and request the setup.

A new Gateway entry will be added to the Gateways view.

To remove a gateway connection, see: Removing gateway connections.

Save and close setups

How to save a setup

To save a setup, do any of the following:

  • Go to File >Save in the menu.
  • Press Save current document on the main toolbar.
  • Press Ctrl+S on your keyboard.

Before saving the document, the editor performs a Schema validation (See Error's view). If there are any errors, you will see this dialog:

gse1

If you select Yes, the document is saved.

If you select No, the save is cancelled.

Note: If the setup has not been changed the save button and menu item remain inactive.

To save a copy of the setup to disk, use File > Save As. See The menu structure for more information.

How to close a setup

To close a setup, do any of the following:

  • Select File > Close in the menu.
  • Right- click on the document tab and select Close.
  • Press Ctrl+F4 on your keyboard.

The following dialog box appears if the setup has been changed:

gse2

If you select Yes, the document is saved and then closed.

If you select No, the document is saved, and any changes are discarded.

If you select Cancel, the document remains open.

The Application window

An example of the main application window is shown in below:

gse3

Like most standard applications it has a menu and a tool bar, the contents of which are detailed below. It also has a set of components which are used to view and manipulate the contents of gateways setup files. All the components reside in dockable frames (see section Gateway Setup Editor) which can be dragged around the application window or undocked (floated in their own window)

The list of components in the GSE is detailed in section Gateway Setup Editor. Using and manipulating dockable windows is the subject of the section: The Dockable framework.

At any given time only a single dockable component is selected. This is indicated by giving it a different colour heading to the other visible components.

The status bar

The status bar (at the bottom of the main application window) displays the build number (version) of the GSE, and the schema version when a document is active.

gse4

General interface standards and conventions

This section outlines some general standards and tips and tricks in the GSE interface.

The menu structure

The following menu options are available in GSE:

  • File
    • New — Create new setup file.
    • Open — Open an existing setup file from disk.
    • Close — Close the current setup file.
    • Connect — Connect to a Geneos Gateway 2.
    • Save — Save the current file.
    • Save as — Save to a new location on disk
    • Replace contents — Replace the active document with the contents of another setup from disk.
    • Reload — Reload the current document. This will revert to the last save point.
    • Load all includes — Load all the included files.
    • Load running setup — Open a read-only copy of the current setup of the connected Gateway in a new editor tab.
    • Exit — Exit the setup editor.
  • Edit
    • Copy — Copy the current selection in the navigation.
    • Paste — Paste a previously copied item into the current selection in the navigation.
    • Rename — Rename the current selection in the navigation (Named items only).
    • Delete — Delete the current selection in the navigation.
  • View
    • Show/Hide empty sections — Toggles the 'show' mode of the navigation tree.
    • Back — Moves back in the navigation tree history.
    • Forward — Moves forward in the navigation tree history.
    • Help — Shows the Help dockable.
    • Search results — Shows the Search results dockable.
    • Errors — Shows the errors dockable.
    • Navigation — Shows the Navigation dockable.
  • Schema
    • Switch... — Switch the schema for the current document to a specific schema.
    • Switch to working schema — Switch to the 'working' schema, after having used 'Switch schema'.
  • Tools
    • Search — Opens the search dialog.
    • Advanced Search — Opens the advanced search dialog.
    • Validate — Validates the current document.
    • Lock* — Sends a request to lock the current document.
    • Force Lock* — Sends a request to force lock the current document.
    • Unlock* — Sends a request to unlock the current document.
    • Force Unlock* — Sends a request to force unlock the current document.
    • Get Lock information* — Sends a request for lock information about the current document.

*These items are only available when editing a file through a gateway connection

  • XML Editor
    • Format** — Format the XML
    • Revert** — Revert the XML to the first state
    • Find...** — Show the find dialog for the XML Editor
    • Apply** — Apply the XML to the document

**These items are only active when an XML Editor is enabled

  • Help
    • Help — Launches the help.
    • About — Launches the 'About' dialog. From this you can also create a diagnostic file to send to ITRS Support in the case of problems. See section Start up settings.

The Toolbar

The toolbar contains the functions shown in Figure 2.

gse5

Figure 2. The GSE toolbar

Component List

The GSE is composed of a number of components (or views). They can be accessed via the View menu in the application menu bar. Each component is contained in its own dockable frame (see section Gateway Setup Editor). The available components are summarised here, and discussed in detail in the following sections:

  1. Navigation - Shows the main sections and items in the setup, and controls the Settings editor of the current document
  2. Errors View - Shows a list of validation errors for the current document
  3. Search Results - Shows the search results for the last executed search
  4. Gateways View - Shows any connected gateways
  5. The Document Area - Shows all the open documents
  6. Settings Editor - Shows the selected section for editing

Icons and colours

The GSE uses icons to represent various types of data in a setup. This section shows examples of these icons.

Icons

The following icons are used throughout the application to represent the sections of the setup:

Named Item Section Icon
Probe Probes gse47
Managed entity Managed entities gse49
Type Types gse104
Sampler Samplers gse48
Action Actions gse105
Command Commands gse106
Schedules command Schedules commands gse107
History period Rules gse108
Rule Rules gse109
Active time Active times gse110
Table Database logging gse111
Item Database logging gse112
User Authentication gse113
Group Authentication gse114
Environment Environments gse115
Audit output Audit outputs gse116
URL template Knowledge base gse117
KBA set Knowledge base gse118
FKM Table Static variables gse119
GL-names Static variables gse119
RMC templates Static variables gse119

The Dockable framework

See Active Console 2 guide.

The Navigation Dockable

The navigation view is the main interface for moving around setups.

gse7

Modify the setup using the navigation

How to create sections

To create a section that has not been created, click on the node in the tree. You are presented with the dialog:

gse9

If you select Yes, the section is created, the icon changes, and the Settings editor shows the new section for editing.

If you select No, the operation is cancelled.

How to create named items

Named items can be created in many different sections in the setup. To create a named item, right click on a section to show the context sensitive menu.

If named items can be created in that section, they will be visible at the top of the menu:

gse10

Select the type of item you wish to create. The items will be added at the bottom of the section, and the item will be loaded into the settings editor.

How to change the name of named items

To change the name of a named item, you can do any of the following:

  • Right-click on the item and choose Rename.
  • Double click on the item.
  • Select the item and press F2.

The item text will become editable, and the text can be changed:

gse13

To commit the changes you have made, press Enter on your keyboard, or click somewhere else in the editor. To revert the change, press Escape on keyboard.

How to change the order of named items

Named items can be moved within each section. To move an item up or down, right click on the item you wish to move, and select Move up or Move Down. Alternatively you can use Alt+ or Alt+ respectively.

You can also sort named items alphabetically in a section, by right clicking on a section and selecting Sort -> Ascending or Sort -> Descending.

How to delete sections and named items

To delete any section, you can do any of the following:

  • Right-click on the item and select Delete.
  • Press the Delete selection button in the toolbar.
  • Press Delete on your keyboard.

You will be prompted to confirm the action:

gse11

Note: This will delete the section and all the items inside the section.

How to move named items

The order of the sections is fixed, however 'Named Items' can be moved around in the setup within each section.

Some named items can be moved within a section or to other sections by using drag and drop:

  1. Drag the item in question to the target section. If the item cannot be moved to the section, the cursor changes to indicate the move is not permitted.
  2. If you drag using the right mouse button, you are presented with a context menu when you release the button:
    gse12
  3. Select Move Here to move node, or Cancel to abort the move.

How to copy named items

There are several ways to copy named items within a section or to other valid sections:

  1. Clicking using your mouse:
    1. Right-click the item and select Copy.
    2. Right-click on the target location and select Paste.

    Note: Paste only shows if the target location is valid for the copied item.

  2. Dragging and dropping using your mouse:
    1. Drag the item in question to the target section using the right mouse button.
      • If the item cannot be copied to the section, the cursor will change to indicate the move is not permitted.
    2. Select Copy Here to copy the item, or Cancel to abort.
  3. Using your keyboard:
    1. Select the item you wish to copy, and press Ctrl+C.
    2. Select the target node and press Ctrl+V.

When copying a Named item as a child of the same parent, the editor changes the name of the new item to 'Copy of <original name>' where <original name> is the name of the item being copied. If the item is being copied to a different parent, the 'Copy of' prefix is not used.

If this name already exists, the editor appends a number on the end (1, 2, 3 etc) until it finds a name that is not in use.

When copying a named item to its parent by using drag and drop with right mouse button, the following context menu appears:

gse14

Note: The option for Move Here does not appear if you are dragging a named item to its immediate parent.

How to copy named items via the system clipboard

When you right click a named item, there is also a Copy XML option. This copies the XML representation of the item (as you would see in the XML editor) to the system clipboard. This is the same as if you opened the item in the XML editor, pressed Ctrl+A (Select All), and then Ctrl+C. You can also do this by selecting an item and pressing Crtl+Shift+C.

If the system clipboard contains well-formed XML representing a single named item and you select a section or item that is a valid parent for that item, the right-click menu contains a Paste XML item and the Ctrl+Shift+V keyboard shortcut is enabled. If you use the Paste XML menu item or Ctrl+Shift+V shortcut, a named item will be created using the clipboard content.

If the name specified for the item in the XML already exists, a number will be appended to make the name unique.

If the XML used contains errors (well-formed XML but not valid according to the schema), these will be indicated in the same way as if invalid XML had been entered into the XML editor.

Note: Copy XML and Paste XML are only provided for named items, not for top-level sections such as 'Samplers' or 'Rules'. You can only copy or paste one item at a time as XML.

The XML which is copied and pasted is a single element, not a complete XML document - it does not start with <?xml version="1.0" encoding="ISO-8859-1"?>.

How to disable and enable named items

Named items in the setup can be disabled. When a named item is disabled, the Gateway will ignore it. Disabling named items allows you to remove it from the setup without deleting it.

Disabled items are displayed 'grayed out' in the tree:

gse15

To disable an item in the navigation, right-click on the item and select Disable, or select the item and press Ctrl+D on the keyboard.

To enable an item in the navigation, right-click on the item and select Enable, or select the item and press Ctrl+D on the keyboard.

Other Navigation features

Quick Filter

The quick filter allows you to hide items, or filter them out.

To enable the quick filter, right click on the navigation and select 'Quick Filter'. The filter appears at the top of the component:

gse16

Simply type some text into the text field, and the tree will be filtered according to the text:

gse17

The tree will hide any items that do not match the text and do not contain any items that match the text. Items that do match will be in bold.

To disable filtering, press the red cross button to the left of the filter, or right click on the tree and select 'Quick Filter'.

Note: The tree becomes read only when filtering is enabled; you will not be able to change, move or delete any items in the tree.

Error Highlighting

When you perform a validate command (See Errors Dockable), the location of the errors will be highlighted in the navigation:

gse18

Any node highlighted indicates an error in that section, or an error in some child section. In the above diagram, 'ProbeWithErrors' has an error, so all of its parent nodes are highlighted.

Additional information

Some nodes in the tree also show additional information:

gse19

This typically gives a preview of some useful piece of information about a part of the setup. E.g. for a probe it shows the host and the port.

The Errors Dockable

The Errors dockable lists validation errors generated by the editor and gateway. To generate a list of errors, either:

  • Select Tools > Validate.
  • Press Validate current document in the toolbar.

Saving the current document also runs the validation process.

Error types

There are three type of error:

Type Icon Description Example
Warning gse20 Indicates a part of the setup may be invalid, but the problem is not serious enough to prevent other parts of the setup from working. Create a managed entity with no samplers.
Error gse21 Indicates an error in a section that will probably result in that section not working correctly. Create a managed entity without specifying the probe that it should run on.
Critical gse22 Indicates an error that will prevent the whole setup from working. Create malformed XML in the XML editor.

Validation types

There are two types of validation that the setup editor performs:

Validation type Description
Schema Validation These are errors validated against the schema. The Schema includes information about data types, but not relationship between sections. This type of validation always occurs.
Gateway Validation The gateway processes the setup and generates errors based upon the data. This includes checking the relationship between sections. This type of validation only occurs when editing a setup via a Gateway connection.

The error table

The errors are displayed in a table format:

gse23

Table Heading Description
Type The type of the error (See 'Error types')
Error An English description of the error
Section The navigation section, if the error has it
Source The validation type. Either 'Schema Validation' or the name of the Gateway for Gateway validation
Document The document (setup) that generated the error

Double clicking on an item in list will select the relevant section in the navigation, and load the section in the settings editor.

Filtering errors by navigation

You can filter errors by navigation sections to make it easier to views errors in individual sections. Simply select the check box to the right of the information bar:

gse24

When you change the selection in the navigation, the errors list will change to show only those errors in that part of the setup.

The Search Results Dockable

The Search Results table

The search results are displayed in a table format:

gse26

Table Heading Description
Document The document (setup) that contains the search match
Section The navigation section that contains the search match

Double clicking on an item in list will select the relevant section in the navigation, and load the section in the settings editor.

Disabled items are shown with the section names crossed out, as seen for the managed entities and alert hierarchies in the example above.

The Gateways Dockable

The gateways view is a list of all the connections, in the form of Gateways:

gse27

You can add new Gateway connections by selecting File->Connect. This will add the connection and automatically open the setup.

You can open a setup for a gateway, by double clicking on the item in the gateway view. If the setup is already open, it will select it in the editor.

Removing gateway connections

When running the GSE standalone (not from the ActiveConsole) you can remove gateway connections by deleting them.

Right click on a gateway in the gateways dockable, and select 'Delete gateway' or select a gateway and press Delete on the keyboard.

The Document area

Document tabs

The document tabs are at the top of the central editing area:

gse28

There is a tab per each open document. Selecting a tab will bring that document to the front, and show the navigation for the document in the navigation view.

To the right of the tab area there are three buttons. The left and right arrows allow you to 'scroll' the tabs along when they are not all visible. The third button shows a list of all the open documents for selection:

gse29

Right clicking on a tab will present a context menu. If more than one document is open, you will see this menu:

gse30

Menu Description
Close Close the document clicked on
Close Others Close all the other documents
Close All Close all open documents
Next Select the next tab
Previous Select the previous tab
New Horizontal Group Splits the document view horizontally
New Vertical Group Splits the document view vertically

The Setting editor

The settings editor is the main area in the centre of the editor:

gse31

This section explains how this part of the editor is structured.

Section Tabs

The settings are normally sectioned into tabs:

gse32

Although every section is different, typically there at least two tabs:

Tab name Description of contents
Basic Compulsory and commonly used settings
Advanced and Other tabs Optional settings, used less often

Indicators

Indicators are used in the settings editor to indicate if settings are compulsory or optional, and if they are in an invalid state:

gse33

This table explains the meaning of the indicators:

Indicator Icon Description
Compulsory gse96 The setting is compulsory, and is in a valid state
Compulsory and invalid gse97 The setting is compulsory, and is in an invalid state
Optional and not created gse98 The setting has not been created
Optional gse99 The setting is optional, and is in a valid state
Optional and invalid gse100 The setting is optional, and is in an invalid state

When a setting is in an invalid state, you can move the mouse over the setting to see a description of the problem:

gse35

Creating and removing settings

Optional settings that have not been created are shown 'greyed out':

gse36

To create the setting, either right click on the setting and select 'Create <name of setting>' or simply click on the setting component or its label.

The setting will change to look like this:

gse37

Once the setting is created, it can be removed by right clicking and selecting 'Remove <name of setting> or pressing the 'X' to the right of the setting.

Table settings

Some settings have multiple instances, or rows. These setting are presented in a table format:

gse38

To add a row to the table, click the 'Add new' link at the bottom of the table.

To remove a row, press the 'X' at the beginning of each row.

Referencing 'Named items'

Some settings reference named items in the setup (e.g. a Managed Entity references a Probe).

These settings are always combo boxes, and they always have an arrow to the right of the combo box:

gse39

To select a reference simply press the arrow to the right of the combo box and select the reference of your choice.

Jumping to and creating referenced items

To jump to a referenced item, simply click on the arrow to the right of the combo box:

gse40

In some situations you may wish to create a new referenced item from this component. To do so, simply type in a new name (one that is not in use for this type), and press the arrow. You will be presented with a dialog:

gse41

Press 'Yes' to create the new item. The editor will create the new item, and select it for editing. Press 'No' to cancel the operation.

In some circumstances there will be more than one possible place to insert the new item. If this is the case you will see a dialog similar to this:

gse42

Simply select the location you wish to use and press 'OK'.

Data/Variable settings

Some settings can be Data or Variables. An example of this is the Sample interval of a managed entity: The interval can either be data (an integer value in seconds) or a variable value (which must also be an integer type)

Data/Variable settings always have data or var link directly after the label and before the component:

gse43

The link acts a toggle, switching the component between a data and a variable.

A variable setting is reference to a named item elsewhere in the setup (See Referencing 'Named items')

String variable settings

String variable settings are a mixture of string constants, and variables.

String variable settings always consist of a text field, and drop down menu with all the variable values inside:

gse44

The Gateway will substitute the variables at runtime, and concatenate the values together.

Example:

Define two variables:

Variable 'var1', Type: Integer, Value: 10
Variable 'var2', Type: Boolean, Value: true

String variable value in editor:

The value of var1 is $(var1), and var2 is $(var2)

The Gateway substitutes the values, giving the final string:

The value of var1 is 10 and var2 is true

Comments

Comments can be set on most settings. To create a comment, right click on the setting, and select 'Create comment'.

A text area will appear below the setting:

gse57

Simply type the comment text, then press 'Escape' when you finished, or click somewhere outside the comment box.

The setting will now have a new icon to show it has a comment set:

gse58

You can edit the comment by clicking the icons.

To view the comment, move the mouse over the setting:

gse59

To remove a comment, right click on the setting and select 'Remove comment'.

Comments on names

When setting the comment on the name of a 'named item', the comment will appear at the top of the editor:

gse60

Getting Help

To show context sensitive help for a setting, right click on the setting and select 'Help':

gse61

XML editor

The XML editor allows you to edit the underlying XML of the setup, bypassing the standard user interface.

To start the XML editor for section, select the section in the main navigation, and then select XML from the combo box at the top right of the setting editor:

gse62

The XML editor has several functions, all of which are available from the main toolbar, the XML editor menu, or using the context menu by right clicking in the editor.

These functions are:

Function Description
Format Formats the XML according to a predefined style.
Revert Reverts the XML text to the state it was in when the editor was enabled.
Find Shows a find dialog for performing text searches in the editor.
Apply Applies the current XML to the editor.

Once you have finished editing the XML, you should apply it to make sure the changes are valid.

You can apply the changes by pressing 'Apply' on the main toolbar, or switching back to normal mode using the combo box at the top right of the setting editor.

If the XML is invalid, you may see this dialog:

gse63

You must fix the error before you can save the setup.

Find function in XML editor

In the Find dialog, you can use wildcards or regular expressions in your searches.

To do this, tick the Use box and select Regular Expressions (default) or Wildcards. You can then use the button to the right of the search box to add regular expressions or wildcards to your searches.

After pressing Find, click on the XML editor and use F3 to cycle through your matched items in a search.

Rule editor

The Rule editor is the text area at the bottom of a rule:

gse64

The rule editor is a syntax highlighting code editor, for the 'Geneos' language.

Templates and Code assistance

The editor has some predefined templates to assist you. To use a template, right click on the editor and then select 'Templates'. The code will be inserted at the cursor position:

gse65

The templates are not complete; they require you to modify the code with appropriate values.

Fixing errors

If your rule code contains errors you will not be able to save the setup. You must fix any code errors first.

Errors are indicated in two ways in the rule editor:

gse66

Errors are underlined in the text, and they are indicated in the error bar on the right hand side.

Refactor

Refactoring allows you to globally change the name of a 'named item', and all of its references.

To start refactoring, right click on a 'name item' in the navigation and select 'Refactor'. Alternatively, right click on the name setting in the setting editor and select 'Refactor'.

The Refactor dialog will open:

gse67

The dialog is made of two parts; the new name and the items that will be changed. To perform the refactor operation, change the name in the 'New name' field, then select the items you wish to change in the list at the bottom of the dialog. Finally press the 'Refactor' button.

You should see the dialog change. It now displays the number of items that have been refactored.

You can see an example below:

gse68

The Refactor dialog will remain open, in case you wish to rename the items again. Press the 'Close' button to dismiss the refactor dialog.

File Locking

Gateway 2 has file locking mechanism's which can be accessed through the Gateway setup editor.

These features are only available when editing a setup through a gateway connection.

Obtaining and releasing a lock

To obtain a lock select Tool->Lock, or press the 'Lock the current document' in the toolbar. If you were able to get lock you will see this dialog:

gse69

If the lock was unsuccessful, you will see this dialog:

gse70

Note: You cannot obtain the lock twice! If the lock failed you can find out who has the lock by getting lock information (See 'Getting lock information').

If the lock has failed because another user already has the lock, you can Force lock (Tools->Force lock). This will remove the current lock (if any), and obtain the lock.

To release the lock select Tools->Unlock, or press 'Unlock the current document' in the toolbar. You should see this dialog:

gse71

If the unlock was unsuccessful, an error will be displayed. You cannot unlock if you do not own the lock, or the file is not locked.

Getting lock information

At any time you can get lock information for a setup. To get lock information, select Tools->Get lock information, or press 'Get lock information on the current document'. You will see a dialog like this:

Lock information:

Name Description
MainSetupFile Yes, if the lock is on the main setup file. No if it is an 'include' file
Locked Yes if the file is locked, No if the file is not locked
ConnectionId The internal connection id
GatewayId The gateway id
Username The username of the user who locked the file. ActiveConsoleX indicates an anonymous logon.
Workstation The Hostname or IP address of the workstation that got the lock
LockedTime The date and time the lock was obtained.

Losing the lock

It is possible for another use the 'force lock' a file. This will remove the current lock, if there is any. If you have lock and this happens, you will see the following dialog:

gse73

Autolock

When a gateway is started, it is possible to specify a parameter such that the GSE will automatically take the lock if connected to the gateway. To start the gateway in this mode, launch it with the -autolock parameter.

With the autolock feature running, if the GSE connects to the main setup for the running gateway and the lock is available, the following message is displayed

gse74

Users should reply "Yes" to this question if they are planning to possibly update the setup; they should only reply "No" if they are definitely only planning to read and not update the setup. Having replied "Yes", the GSE will load the main setup and will display a message next to the top level to indicate that it is now locked, as illustrated below.

gse75

If the GSE attempts to connect to a running gateway with the autolock feature active, and the lock is not available, it will load the setup but will display a message against the top level to show that it is already locked by someone else, as illustrated below.

gse76

Note: If gateway authentication is not in use, a more generic message may get displayed such as "Locked by ActiveConsole1".

In this state, the user does not have the lock, and will be unable to write any changes back to the gateway server. However, if you leave the GSE in this state, and the lock subsequently gets released by the other user who was holding it, the fact that the lock is now available will get automatically detected and a message will be displayed saying

gse77

If the user replies "Yes" to this question, then the main setup will be reloaded and they will have the lock for it.

Autolocking works in the same way for Include Files. With the autolocking feature active, when the user clicks on an include file to load it, the lock will automatically be taken if it is available. A message will now be shown next to the include file setup to indicate that it is now Locked, as illustrated below.

gse78

If, however, another gateway also shares this include file, and a GSE connected to that gateway has already taken the lock on the include file, when the user attempts to load the include file it is still loaded but the user does not get the lock. This is shown by a message next to the include file setup, as illustrated below.

gse79

In this state, the user does not have the lock on the include file, and will be unable to write any changes made to the include file back to the gateway server.

Note: The user does still have the lock on the main setup file. The user can still make changes to the main setup file and save them back to the gateway server, they are only restricted from changing the include file.

Having made changes to the main setup, when the user tries to save the changes they will get a message of the form

gse80

By replying "Yes" to this message, the main setup changes will be saved.

If the lock on the include file is initially held by someone else, but the other user who was holding the lock subsequently releases it, the fact that the lock is now available will get automatically detected and a message will be displayed of the form

gse81

If the user replies "Yes" to this question, then the include file will be reloaded and they will have the lock for it.

'Include' files

Gateway 2 allows you to 'include' multiple files into the main setup. The files are merged by the gateway to produce the overall setup.

Creating an include file

To create an include file you must first create the 'Includes' section. Click on includes in the navigation section:

gse82

To create an include file, right click on Includes, and select 'New Include'.

An include file is not a 'named item'. The text in the 'name' is actually its location, or path. Type in the path to a file in the location field:

gse83

Note: The path is relative to the main setup file location.

Loading an include file

Included files are not automatically loaded as part of the main setup. To load a setup, you must expand the include node in the navigation tree, and click on the node 'Click to load...'

gse84

If the main setup file was loaded from a gateway connection, the editor will request the include file from the Gateway. If the file was loaded from disk, the editor will attempt to load the include file from disk.

Once the include file is loaded, the structure is the same as the main setup file, and editing is performed in exactly the same way.

Schema

What is a schema?

A schema is an XML document that describes the content of another XML document. In the case of the GSE, the schema describes the settings that can be configured for the Gateway, along with any Netprobe and Plug-In configuration that is sent to Netprobes.

The GSE reads the schema, and uses it to construct the GUI. This is presented to the user in two places; the navigation and the settings editor. A change in the schema can result in the structure of these components changing.

The schema also contains restriction information, enabling the GSE to validate the input, and provide useful feedback to the user.

A full description of XML Schema is beyond the scope of this manual. For comprehensive description, please refer to http://www.w3.org/XML/Schema

Schema versioning

Schemas in the Geneos system are versioned using the same convention as all other Geneos components:

<Branch>-<YYMMDD>

e.g.: GA-091212

The GSE ships with the latest version of the schema at the date of release, which it uses to create new setup files. Each setup file contains a reference to the schema version and the GSE then uses that working schema version for editing the setup. When connected to a Gateway, GSE will use the schema version that the Gateway uses, however this version may change if the Gateway gets upgraded.

If the schema in GSE is upgraded, new settings might become available, as well as some settings may be hidden due to deprecation. It is recommended to use the version that the Gateway uses.

Once GSE has obtained the latest available version from the Gateway, it will use that version when creating new setups.

Determining Schema Version

The schema version for the active document is displayed in the status bar at the bottom right of the GSE window.

The version status bar can be in these states:

State Example Status bar Description
Normal gse93 The document is using the working schema
Alternate schema gse94 The document is using an alternate schema, i.e. a schema loaded from disk by the user
Incorrect schema gse95 The document is using a different version of the schema than the one specified

If you move the mouse over the schema version, a tooltip will give you extra information.

Switching to Alternate Schema

In some scenarios it may be necessary to switch to an alternate schema. To do this, go to Schema -> Switch…. You must pick a valid schema from the file chooser.

The dialog will show you the schema version number when you select valid files:

gse87

The status bar will change to indicate that you are using an alternate schema:

gse88

At any time you can switch back to the working schema by choosing Schema->Switch to working schema.

Loading Setup with Alternate Schema

If you load a setup that was previously saved using an alternate schema, either by you or by another user, then GSE will offer to choose between the current and that special schema.

gse89

If the alternate schema is unknown to GSE, it will ask the user to locate that schema on the disk. This can happen if the schema was edited by another user.

gse90

Gateway Schema Change

The gateway will publish its current schema version, however it may change if the Gateway or a Probe connected to that Gateway is upgraded. If the schema changes while the Gateway's setup is being edited, GSE will show a notification and will offer to load the new schema.

gse91

Deprecated settings

When GSE schema is upgraded, some settings may be hidden due to deprecation unless they already have a value. To view all the deprecated settings anyway, choose View->Show deprecated. All such settings will be marked with a warning sign.

gse92

Start up settings

There are a number of startup flags and settings you can define which modify the behavior and configuration of the GSE while it is running. These settings are configured by modifying the GatewaySetupEditor.gci file that resides in the same directory as the GatewaySetupEditor.exe. This file is a text file, so can be edited in any text editor.

The file that is shipped with GSE will look something like this:

############################################################
#### The java class that has 'main'
############################################################
-mainclass
com.itrsgroup.gse.GatewaySetupEditor

############################################################
#### The JVM to use and arguments
############################################################
-jvm
.\JRE\bin\client\jvm.dll
-jvmargs
Xmx128M
Ddocking.floatingContainerType=frame

############################################################
#### Misc
############################################################
#The jvm depends upon dll's in this directory (e.g. msvcr71.dll)
-path
JRE\bin
-logexceptions
-gsedir
gse

The syntax

The file is newline delimited; each flag starts with a hyphen. Any arguments for a given flag are again separated by a newline. Any lines that begin with '#' or are empty are ignored.

#comment1
-<Flag1><Flag1Arg>…#comment2
<Flag2><Flag2Arg>…

GatewaySetupEditor.exe flags

See ActiveConsole.exe flags

Troubleshooting

Please search the Frequently Asked Questions area on the ICE website.

Reporting Faults and suggesting enhancements

If you experience problems when using GSE then you can report those using ITRS's helpdesk. Issues can be raise via emailing helpdesk@itrsgroup.com or directly on http://helpdesk.itrsgroup.com/helpdesk/

When creating an issue report it will help speed up the bug fixing process if you could attach a diagnostic file, which is generated via the 'Help ► about' dialog. See below for an example.

gse102

On the new issue page this diagnostic file can be connected to the issue report via the 'Upload file' button, see below for an example.

gse103

iTrack can also be used to register enhancement requests with ITRS